New Version 2016
InstallShield: Pré-requis

Comment les programmes d'installation MSI et EXE et les packages UWP et WSA pour les applications Windows sont créés

Pré-requis

Conditions système requises pour InstallShield® 2016

InstallShield est la solution numéro un pour le développement de programmes d'installation pour la création de packages App-V et de programmes d'installation MSI pour les applications Windows. Les conditions minimales requises pour les systèmes exécutant InstallShield (environnement de programmation), ainsi que pour les systèmes cibles qui exécutent les installations créées avec InstallShield (environnement d'exécution) sont les suivantes.

Pour les systèmes exécutant InstallShield

Processeur PC de classe Pentium III (500 MHz ou supérieur recommandé)
RAM 256 Mo de RAM (512 Mo recommandés)
Disque dur 500 Mo d'espace libre
Écran Conçu pour une résolution XGA de 1 024 × 768 ou supérieure
Système d'exploitation

Windows Vista
Windows Server 2008 
Windows 7
Windows Server 2008 R2
Windows 8
Windows Server 2012
Windows 8.1
Windows Server 2012 R2
Windows 10
Windows Server 2016

Privilèges Privilèges d'administration sur le système
Souris Microsoft IntelliMouse ou autre dispositif de pointage compatible
Intégration optionnelle avec Visual Studio

Vous pouvez intégrer les versions suivantes de Microsoft Visual Studio avec les éditions Premier ou Professional d'InstallShield :

  • Visual Studio 2008
  • Visual Studio 2010
  • Visual Studio 2012
  • Visual Studio 2013
  • Visual Studio 2015
  • Visual Studio 2017

Vous pouvez intégrer les versions suivantes de ces versions de Microsoft Visual Studio avec les éditions Premier ou Professional d'InstallShield :

  • Community
  • Professional
  • Premium
  • Ultimate

Pour les systèmes cibles

Remarque : Pour tous les types de projets, à l'exception des Suites (types de projets Advanced UI et Suite/Advanced UI), Windows XP SP3 et Windows Server 2003 SP2 sont les versions minimales de Windows requises pour les systèmes cibles qui exécutent les installations créées dans InstallShield. Pour les Suites, Windows Vista et Windows Server 2008 sont les versions minimales de Windows requises pour les systèmes cibles.

Les systèmes cibles doivent remplir les conditions minimales suivantes pour les systèmes d'exploitation :

  • Windows XP SP3
  • Windows Server 2003 SP2
  • Windows Vista
  • Windows Server 2008
  • Windows 7
  • Windows Server 2008 R2
  • Windows 8
  • Windows Server 2012
  • Windows 8.1
  • Windows Server 2012 R2
  • Windows 10
  • Windows Server 2016

Les systèmes cibles doivent également prendre en charge l'ensemble d'instructions SSE2.

Retour à InstallShield