FlexNet Licensing: Pré-requis

Protégez et monétisez votre propriété intellectuelle grâce à une technologie robuste de gestion des licences logicielles : applications sur site, SaaS, en cloud, virtualisées et embarquées

Pré-requis

Voici les systèmes d'exploitation et les types de processeurs pris en charge par FlexNet Publisher. Les plates-formes FlexNet Publisher sont définies par la combinaison d'un système d'exploitation et d'un processeur particulier. Chaque plate-forme fait l'objet d'une licence de manière individuelle et vise à servir autant de systèmes d'exploitation, de processeurs et de configurations que possible.

Remarque : les clients qui souhaitent développer une application Java doivent également acquérir FlexNet Publisher Oracle Java Development Kit en complément de la plate-forme cible pour l'application.

Windows 7 Logo LSB Logo

Système d'exploitation Processeur Version Notes
AIX 32 bits
  • PowerPC
  • AIX 6.1 ML 006
  • AIX 7.1 ML 000
  • Les transactions de code court ne sont pas prises en charge.
  • Par défaut, les bibliothèques client sont PIC. C'est pourquoi une seule version de ces bibliothèques est fournie dans le kit.
  • Java SDK n'est pas pris en charge.
  • Les applications inviolables ne sont pas prises en charge.
AIX 64 bits
  • PowerPC
  • AIX 6.1 ML 006
  • AIX 7.1 ML 000
  • lmadmin est pris en charge via son code binaire de 32 bits. (Aucun code binaire lmadmin de 64 bits n'est disponible.)
  • Les transactions de code court ne sont pas prises en charge.
  • Vous devez utiliser « ar -X64 » et « strip -X64 » sur cette plate-forme.
  • Par défaut, les bibliothèques client sont PIC. C'est pourquoi une seule version de ces bibliothèques est fournie dans le kit.
  • Java SDK n'est pas pris en charge.
  • Les applications inviolables ne sont pas prises en charge.
HP-UX 64 bits
  • Itanium
  • HP-UX 11i v3
  • Les transactions de code court ne sont pas prises en charge.
  • Les applications inviolables ne sont pas prises en charge.
Java Development Kit
  • Toute version 32 bits ou 64 bits d'Oracle JVM
  • Oracle Java Standard Edition 1.7
  • Nécessite des licences inviolables (TRL) pour être activé.
  • Nécessite un environnement de développement en C pour pouvoir générer des licences ou prendre en charge un stockage sécurisé.
  • Met en œuvre l'API FlexNet Licensing uniquement pour la bibliothèque client Java.
  • Les applications inviolables ne sont pas prises en charge.
Linux 32 bits
  • x86
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6
  • SUSE Linux Enterprise 10
  • SUSE Linux Enterprise 11
  • Imadmin est pris en charge uniquement sur x86.
  • Les transactions de code court sont prises en charge (RHEL x86 uniquement).
  • VMware ESX Server 4.0 et 4.1 sont pris en charge sur x86.
  • VMware Workstation 7.1 est pris en charge sur x86.
  • Microsoft Windows Server 2008 R2 Hyper-V est pris en charge sur x86.
  • Microsoft Hyper-V Server 2008 R2 est pris en charge sur x86.
  • Citrix XenServer 6.0
Linux 64 bits
  • x86-64
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 6  
  • SUSE Linux Enterprise 10
  • SUSE Linux Enterprise 11
  • lmadmin est pris en charge via son code binaire de 32 bits. (Aucun code binaire lmadmin de 64 bits n'est disponible.)
  • Les transactions de code court ne sont pas prises en charge.
  • VMware ESX Server 4.0 et 4.1 sont pris en charge sur x86-64.
  • VMware Workstation 7.1 est pris en charge sur x86-64.
  • Microsoft Windows Server 2008 R2 Hyper-V est pris en charge sur x86-64.
  • Microsoft Hyper-V Server 2008 R2 est pris en charge sur x86-64.
  • Citrix XenServer 6.0
Apple OS X 32 bits
  • x86
  • OS X 10.9
  • OS X 10.8
  • OS X 10.7
  • OS X 10.6
  • Universal Binary
Apple OS X 64 bits
  • x86-64
  • OS X 10.9
  • OS X 10.8
  • OS X 10.7
  • OS X 10.6
  • Universal Binary
  • lmadmin est pris en charge via son code binaire de 32 bits. (Aucun code binaire lmadmin de 64 bits n'est disponible.)
Windows 32 bits
  • x86
  • Windows Server 2008, y compris SP1 et SP2
  • Windows Vista, y compris SP1 et SP2
  • Windows 7, y compris SP1
  • Windows 8.x
  • Windows 10
  • Voici les plates-formes de machines virtuelles prises en charge :
  • VMware Workstation 7.1
  • VMware ESX 4.0 et 4.1
  • Microsoft Windows Server 2008 R2 Hyper-V
  • Microsoft Hyper-V Server 2008 R2
  • Citrix XenServer 6.0
Windows 64 bits
  • x86-64
  • Windows Server 2008, y compris SP2 et R2
  • Windows Vista, y compris SP1 et SP2
  • Windows 7
  • Windows 8.x
  • Windows 10
  • Windows Server 2012 et 2012 R2
  • lmadmin est pris en charge via son code binaire de 32 bits. (Aucun code binaire lmadmin de 64 bits n'est disponible.)
  • Voici les plates-formes de machines virtuelles prises en charge :
    • VMware Workstation 7.1
    • VMware ESX 4.0 et 4.1
    • Microsoft Windows Server 2008 R2 Hyper-V
    • Microsoft Hyper-V Server 2008 R2
    • Citrix XenServer 6.0
Solaris 32 bits
  • SPARC-32
  • x86-32
  • Solaris 10
  • Solaris 11
  • Les transactions de code court ne sont pas prises en charge.
Solaris 64 bits
  • SPARC-64
  • x86-64
  • Solaris 10
  • Solaris 11
  • lmadmin est pris en charge via son code binaire de 32 bits. (Aucun code binaire lmadmin de 64 bits n'est disponible.)
  • Les transactions de code court ne sont pas prises en charge.

Informations sur le compilateur :

Pour compiler FlexNet Publisher sous les plates-formes Windows, Unix et Linux, le compilateur suivant est requis. Reportez-vous aux notes de mise à jour pour obtenir des informations supplémentaires.

Système d'exploitation Version du compilateur
AIX 32 bits
  • cc (IBM XLC) 9.0 et 11.1
AIX 64 bits
  • cc (IBM XLC) 9.0 et 11.0
HP-UX 64 bits
  • HP aC++/ANSI C B3910B A.06.05 (Itanium)
Linux 32 bits

Compilateur X86-32 :

  • gcc 4.0.4 (RHEL 5.0)
  • gcc 4.1.2 (RHEL 5.0)
  • gcc 4.4.4 (RHEL 6.0)
  • gcc 3.3.3 (SUSE 9 SP3 ou version ultérieure)
  • gcc 4.1.0 (SUSE 10)
  • gcc 4.1.2 (SUSE 10 et 11)
  • gcc 4.3.4 (SUSE 11)
Linux 64 bits

Compilateur x86-64 :

  • gcc 4.0.4 (RHEL 5.0)
  • gcc 4.1.2 (RHEL 5.0)
  • gcc 4.4.4 (RHEL 6.0)
  • gcc 3.3.3 (SUSE 9 SP3 ou version ultérieure)
  • gcc 4.1.0 (SUSE 10)
  • gcc 4.1.2 (SUSE 11)
  • gcc 4.3.4 (SUSE 11)
Apple OS X 32 bits et 64 bits
  • gcc 4.0.1
  • gcc 4.2.1
Windows 32 bits

MSVC 2005 :

  • Visual Studio 2005, y compris SP1

MSVC 2008 :

  • Visual Studio 2008, y compris SP1

MSVC 2010 :

  • Visual Studio 2010
Windows 64 bits

MSVC 2005 :

  • Visual Studio 2005, y compris SP1

MSVC 2008 :

  • Visual Studio 2008, y compris SP1

MSVC 2010 :

  • Visual Studio 2010
Windows 64 bits Itanium
  • Platform SDK 2003 7.00.8882
Solaris 32 bits

Compilateur X86-32 :

  • cc (Sun C) 5.8
  • cc (Sun C) 5.10
  • cc (Sun C) 5.12

Compilateur SPARC :

  • cc (Sun C) 5.8
  • cc (Forte Dev 7) 5.4
  • cc (Sun C) 5.12
Solaris 64 bits

Compilateur x86-64 :

  • cc (Sun C) 5.8
  • cc (Sun C) 5.10
  • cc (Sun C) 5.12

Compilateur SPARC :

  • cc (Sun C) 5.8

Retour à FlexNet Licensing